dev-qt/qtscript: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-haskell / hxt-regex-xmlschema / hxt-regex-xmlschema-9.2.0.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # ebuild generated by hackport 0.5.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="A regular expression library for W3C XML Schema regular expressions"
12 HOMEPAGE="https://www.haskell.org/haskellwiki/Regular_expressions_for_XML_Schema"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="profile"
19
20 RDEPEND=">=dev-haskell/hxt-charproperties-9:=[profile?] <dev-haskell/hxt-charproperties-10:=[profile?]
21         >=dev-haskell/parsec-2.1:=[profile?] <dev-haskell/parsec-4:=[profile?]
22         >=dev-haskell/text-0.10:=[profile?]
23         >=dev-lang/ghc-7.6.1:=
24 "
25 DEPEND="${RDEPEND}
26         >=dev-haskell/cabal-1.16.0
27         test? ( dev-haskell/hunit )
28 "
29
30 src_configure() {
31         haskell-cabal_src_configure \
32                 $(cabal_flag profile profile)
33 }