dev-haskell/syb: bump up to 0.7.1
[gentoo.git] / dev-haskell / http-reverse-proxy / http-reverse-proxy-0.4.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.6.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="Reverse proxy HTTP requests, either over raw sockets or with WAI"
12 HOMEPAGE="https://github.com/fpco/http-reverse-proxy"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RDEPEND="dev-haskell/async:=[profile?]
21         >=dev-haskell/blaze-builder-0.3:=[profile?]
22         >=dev-haskell/case-insensitive-0.4:=[profile?]
23         >=dev-haskell/conduit-1.1:=[profile?]
24         dev-haskell/conduit-extra:=[profile?]
25         dev-haskell/data-default-class:=[profile?]
26         >=dev-haskell/http-client-0.3:=[profile?]
27         >=dev-haskell/http-types-0.6:=[profile?]
28         >=dev-haskell/lifted-base-0.1:=[profile?]
29         >=dev-haskell/monad-control-0.3:=[profile?]
30         dev-haskell/network:=[profile?]
31         dev-haskell/resourcet:=[profile?]
32         dev-haskell/streaming-commons:=[profile?]
33         >=dev-haskell/text-0.11:=[profile?]
34         dev-haskell/transformers:=[profile?]
35         >=dev-haskell/wai-3.0:=[profile?]
36         dev-haskell/wai-logger:=[profile?]
37         >=dev-haskell/word8-0.0:=[profile?]
38         >=dev-lang/ghc-7.6.1:=
39 "
40 DEPEND="${RDEPEND}
41         >=dev-haskell/cabal-1.16.0
42         test? ( >=dev-haskell/hspec-1.3
43                 dev-haskell/http-conduit
44                 >=dev-haskell/warp-2.1 )
45 "