sys-apps/gawk: stable 5.0.1 for ppc64, bug #725374
[gentoo.git] / dev-haskell / http-conduit / http-conduit-2.2.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # ebuild generated by hackport 0.5.1
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="HTTP client package with conduit interface and HTTPS support"
12 HOMEPAGE="https://www.yesodweb.com/book/http-conduit"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RDEPEND=">=dev-haskell/aeson-0.8:=[profile?]
21         >=dev-haskell/conduit-0.5.5:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
22         >=dev-haskell/conduit-extra-1.1.5:=[profile?]
23         >=dev-haskell/exceptions-0.6:=[profile?]
24         >=dev-haskell/http-client-0.5:=[profile?] <dev-haskell/http-client-0.6:=[profile?]
25         >=dev-haskell/http-client-tls-0.3:=[profile?] <dev-haskell/http-client-tls-0.4:=[profile?]
26         >=dev-haskell/http-types-0.7:=[profile?]
27         >=dev-haskell/lifted-base-0.1:=[profile?]
28         dev-haskell/monad-control:=[profile?]
29         dev-haskell/mtl:=[profile?]
30         >=dev-haskell/resourcet-1.1:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
31         >=dev-lang/ghc-7.8.2:=
32 "
33 DEPEND="${RDEPEND}
34         >=dev-haskell/cabal-1.18.1.3
35         test? ( dev-haskell/blaze-builder
36                 dev-haskell/case-insensitive
37                 >=dev-haskell/conduit-1.1
38                 >=dev-haskell/connection-0.2
39                 dev-haskell/cookie
40                 dev-haskell/data-default-class
41                 >=dev-haskell/hspec-1.3
42                 dev-haskell/hunit
43                 dev-haskell/network
44                 dev-haskell/streaming-commons
45                 dev-haskell/temporary
46                 dev-haskell/text
47                 dev-haskell/utf8-string
48                 >=dev-haskell/wai-3.0 <dev-haskell/wai-3.3
49                 dev-haskell/wai-conduit
50                 >=dev-haskell/warp-3.0.0.2 <dev-haskell/warp-3.3
51                 dev-haskell/warp-tls )
52 "