dev-haskell/colour: bump up to 2.3.5
[gentoo.git] / dev-haskell / http-client / http-client-0.5.5.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # ebuild generated by hackport 0.5.1.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="An HTTP client engine"
12 HOMEPAGE="https://github.com/snoyberg/http-client"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="+network-uri"
19
20 RDEPEND=">=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
21         >=dev-haskell/blaze-builder-0.3:=[profile?]
22         >=dev-haskell/case-insensitive-1.0:=[profile?]
23         dev-haskell/cookie:=[profile?]
24         >=dev-haskell/exceptions-0.4:=[profile?]
25         >=dev-haskell/http-types-0.8:=[profile?]
26         dev-haskell/mime-types:=[profile?]
27         dev-haskell/random:=[profile?]
28         >=dev-haskell/streaming-commons-0.1.0.2:=[profile?] <dev-haskell/streaming-commons-0.2:=[profile?]
29         >=dev-haskell/text-0.11:=[profile?]
30         >=dev-lang/ghc-7.8.2:=
31         network-uri? ( >=dev-haskell/network-2.6:=[profile?]
32                         >=dev-haskell/network-uri-2.6:=[profile?] )
33         !network-uri? ( >=dev-haskell/network-2.3:=[profile?] <dev-haskell/network-2.6:=[profile?] )
34 "
35 DEPEND="${RDEPEND}
36         >=dev-haskell/cabal-1.18.1.3
37         test? ( dev-haskell/async
38                 dev-haskell/hspec
39                 dev-haskell/monad-control
40                 >=dev-haskell/streaming-commons-0.1.1
41                 dev-haskell/zlib
42                 !network-uri? ( dev-haskell/network-uri ) )
43 "
44
45 src_configure() {
46         haskell-cabal_src_configure \
47                 $(cabal_flag network-uri network-uri)
48 }