sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-haskell / http-client / http-client-0.4.18.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.5.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="An HTTP client engine, intended as a base layer for more user-friendly packages"
12 HOMEPAGE="https://github.com/snoyberg/http-client"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="+network-uri"
19
20 RDEPEND=">=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
21         >=dev-haskell/blaze-builder-0.3:=[profile?]
22         >=dev-haskell/case-insensitive-1.0:=[profile?]
23         dev-haskell/cookie:=[profile?]
24         dev-haskell/data-default-class:=[profile?]
25         >=dev-haskell/exceptions-0.4:=[profile?]
26         >=dev-haskell/http-types-0.8:=[profile?]
27         dev-haskell/mime-types:=[profile?]
28         dev-haskell/random:=[profile?]
29         >=dev-haskell/streaming-commons-0.1.0.2:=[profile?] <dev-haskell/streaming-commons-0.2:=[profile?]
30         >=dev-haskell/text-0.11:=[profile?]
31         dev-haskell/transformers:=[profile?]
32         >=dev-lang/ghc-7.4.1:=
33         network-uri? ( >=dev-haskell/network-2.6:=[profile?]
34                         >=dev-haskell/network-uri-2.6:=[profile?] )
35         !network-uri? ( >=dev-haskell/network-2.3:=[profile?] <dev-haskell/network-2.6:=[profile?] )
36 "
37 DEPEND="${RDEPEND}
38         >=dev-haskell/cabal-1.10
39         test? ( dev-haskell/async
40                 dev-haskell/hspec
41                 dev-haskell/monad-control
42                 >=dev-haskell/streaming-commons-0.1.1
43                 dev-haskell/zlib
44                 !network-uri? ( dev-haskell/network-uri ) )
45 "
46
47 src_configure() {
48         haskell-cabal_src_configure \
49                 $(cabal_flag network-uri network-uri)
50 }