Use https by default
[gentoo.git] / dev-haskell / http / http-4000.2.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6
7 CABAL_FEATURES="lib profile haddock hscolour hoogle"
8 inherit base haskell-cabal
9
10 MY_PN="HTTP"
11 MY_P="${MY_PN}-${PV}"
12
13 DESCRIPTION="A library for client-side HTTP"
14 HOMEPAGE="https://github.com/haskell/HTTP"
15 SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz
16                 https://dev.gentoo.org/~gienah/2big4tree/dev-haskell/http/${MY_P}-test-suite.tar.gz"
17
18 LICENSE="BSD"
19 SLOT="0"
20 KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~ppc-macos ~x86-macos"
21 IUSE="test"
22
23 RDEPEND=">=dev-haskell/mtl-2.0[profile?]
24                 <dev-haskell/mtl-2.2[profile?]
25                 dev-haskell/network[profile?]
26                 dev-haskell/parsec[profile?]
27                 >=dev-lang/ghc-6.8.2"
28 DEPEND="${RDEPEND}
29                 >=dev-haskell/cabal-1.8
30                 test? ( >=dev-haskell/cabal-1.10
31                         dev-haskell/hunit[profile?]
32                         dev-haskell/httpd-shed[profile?]
33                         =dev-haskell/split-0.1*[profile?]
34                         dev-haskell/test-framework[profile?]
35                         dev-haskell/test-framework-hunit[profile?]
36                 )
37                 "
38
39 S="${WORKDIR}/${MY_P}"
40
41 PATCHES=("${FILESDIR}/${PN}-4000.2.3-ghc-7.6.patch")
42
43 src_configure() {
44         cabal_src_configure $(use test && use_enable test tests) #395351
45 }