media-gfx/gimp: Depend on media-libs/gegl[cairo] (bug #567724)
[gentoo.git] / dev-haskell / http / http-4000.1.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 # ebuild generated by hackport 0.2.13
6
7 EAPI="4"
8
9 CABAL_FEATURES="lib profile haddock hscolour hoogle"
10 inherit haskell-cabal
11
12 MY_PN="HTTP"
13 MY_P="${MY_PN}-${PV}"
14
15 DESCRIPTION="A library for client-side HTTP"
16 HOMEPAGE="http://projects.haskell.org/http/"
17 SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
18
19 LICENSE="BSD"
20 SLOT="0"
21 KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x86-macos"
22 IUSE=""
23
24 RDEPEND="dev-haskell/mtl[profile?]
25                 dev-haskell/network[profile?]
26                 dev-haskell/parsec[profile?]
27                 >=dev-lang/ghc-6.8.2"
28 DEPEND="${RDEPEND}
29                 >=dev-haskell/cabal-1.2"
30
31 S="${WORKDIR}/${MY_P}"
32
33 src_prepare() {
34         sed -e 's@base >= 2 && < 4.5@base >= 2 \&\& < 4.6@' \
35                 -i "${S}/${MY_PN}.cabal" || die "Could not loosen dependencies"
36 }