Merge remote-tracking branch 'github/pr/703'. Fixes bug 560362.
[gentoo.git] / dev-haskell / hsopenssl / hsopenssl-0.11.1.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.4.4.9999
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal
11
12 MY_PN="HsOpenSSL"
13 MY_P="${MY_PN}-${PV}"
14
15 DESCRIPTION="Partial OpenSSL binding for Haskell"
16 HOMEPAGE="https://github.com/phonohawk/HsOpenSSL"
17 SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
18
19 LICENSE="public-domain"
20 SLOT="0/${PV}"
21 KEYWORDS="~amd64 ~x86"
22 IUSE="+fast-bignum"
23
24 RESTRICT=test # whoops, not good
25
26 RDEPEND=">=dev-haskell/network-2.1:=[profile?] <dev-haskell/network-2.7:=[profile?]
27         >=dev-haskell/old-locale-1.0:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
28         >=dev-lang/ghc-7.4.1:=
29         dev-libs/openssl:*
30 "
31 DEPEND="${RDEPEND}
32         >=dev-haskell/cabal-1.8
33         test? ( >=dev-haskell/hunit-1.0 <dev-haskell/hunit-1.3
34                 >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
35                 >=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4 )
36 "
37
38 S="${WORKDIR}/${MY_P}"
39
40 src_configure() {
41         local fbn_flag=$(cabal_flag fast-bignum fast-bignum)
42
43         # not ported to integer-gmp-1.0:
44         #  https://github.com/phonohawk/HsOpenSSL/issues/36
45         [[ $(ghc-version) == 7.10.* ]] && fbn_flag=-f-fast-bignum
46
47         haskell-cabal_src_configure \
48                 ${fbn_flag}
49 }