dev-haskell/colour: bump up to 2.3.5
[gentoo.git] / dev-haskell / hsopenssl / hsopenssl-0.11.1.1-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.4.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 MY_PN="HsOpenSSL"
12 MY_P="${MY_PN}-${PV}"
13
14 DESCRIPTION="Partial OpenSSL binding for Haskell"
15 HOMEPAGE="https://github.com/phonohawk/HsOpenSSL"
16 SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
17
18 LICENSE="public-domain"
19 SLOT="0/${PV}"
20 KEYWORDS="amd64 x86"
21 IUSE="+fast-bignum libressl"
22
23 RESTRICT=test # whoops, not good
24
25 RDEPEND=">=dev-haskell/network-2.1:=[profile?] <dev-haskell/network-2.7:=[profile?]
26         >=dev-haskell/old-locale-1.0:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
27         >=dev-lang/ghc-7.4.1:=
28         !libressl? ( dev-libs/openssl:0= )
29         libressl? ( dev-libs/libressl:= )
30 "
31 DEPEND="${RDEPEND}
32         >=dev-haskell/cabal-1.8
33         test? ( >=dev-haskell/hunit-1.0 <dev-haskell/hunit-1.3
34                 >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
35                 >=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4 )
36 "
37
38 S="${WORKDIR}/${MY_P}"
39
40 src_prepare() {
41         cabal_chdeps \
42                 'time       >= 1.1.1 && < 1.6' 'time       >= 1.1.1'
43 }
44
45 src_configure() {
46         local fbn_flag=$(cabal_flag fast-bignum fast-bignum)
47
48         # not ported to integer-gmp-1.0:
49         #  https://github.com/phonohawk/HsOpenSSL/issues/36
50         [[ $(ghc-version) == 7.10.* ]] && fbn_flag=-f-fast-bignum
51
52         haskell-cabal_src_configure \
53                 ${fbn_flag}
54 }