dev-haskell/colour: bump up to 2.3.5
[gentoo.git] / dev-haskell / hsopenssl / hsopenssl-0.10.4.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.3.5.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour"
9 inherit haskell-cabal
10
11 MY_PN="HsOpenSSL"
12 MY_P="${MY_PN}-${PV}"
13
14 DESCRIPTION="Partial OpenSSL binding for Haskell"
15 HOMEPAGE="https://github.com/phonohawk/HsOpenSSL"
16 SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
17
18 LICENSE="public-domain"
19 SLOT="0/${PV}"
20 KEYWORDS="~amd64 ~x86"
21 IUSE="+fast-bignum"
22
23 RDEPEND=">=dev-haskell/network-2.1.0.0:=[profile?]
24         >=dev-lang/ghc-6.12.1:=
25         dev-libs/openssl:0=
26 "
27 DEPEND="${RDEPEND}
28         >=dev-haskell/cabal-1.8.0.2
29 "
30
31 S="${WORKDIR}/${MY_P}"
32
33 src_configure() {
34         haskell-cabal_src_configure \
35                 $(cabal_flag fast-bignum fast-bignum)
36 }