*/*: Drop stable ia64 keywords
[gentoo.git] / dev-haskell / hlint / hlint-1.8.57.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.3.6.9999
7
8 CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
9 inherit haskell-cabal elisp-common
10
11 DESCRIPTION="Source code suggestions"
12 HOMEPAGE="http://community.haskell.org/~ndm/hlint/"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="emacs"
19
20 RDEPEND=">=dev-haskell/cpphs-1.11:=[profile?]
21         >=dev-haskell/haskell-src-exts-1.14:=[profile?] <dev-haskell/haskell-src-exts-1.15:=[profile?]
22         >=dev-haskell/hscolour-1.17:=[profile?]
23         >=dev-haskell/transformers-0.0:=[profile?]
24         >=dev-haskell/uniplate-1.5:=[profile?]
25         >=dev-lang/ghc-6.10.4:=
26         emacs? ( >=app-editors/emacs-23.1:* )
27 "
28 DEPEND="${RDEPEND}
29         >=dev-haskell/cabal-1.6.0.3
30 "
31
32 SITEFILE="60${PN}-gentoo.el"
33
34 src_configure() {
35         local threaded_flag=""
36         if $(ghc-supports-threaded-runtime); then
37                 threaded_flag="--flags=threaded"
38         else
39                 threaded_flag="--flags=-threaded"
40         fi
41         cabal_src_configure \
42                 $threaded_flag
43 }
44
45 src_compile() {
46         cabal_src_compile
47
48         use emacs && elisp-compile data/hs-lint.el
49 }
50
51 src_install() {
52         cabal_src_install
53
54         if use emacs; then
55                 elisp-install ${PN} data/*.el data/*.elc || die "elisp-install failed."
56                 elisp-site-file-install "${FILESDIR}/${SITEFILE}"
57         fi
58
59         doman data/hlint.1
60 }
61
62 pkg_postinst() {
63         ghc-package_pkg_postinst
64         use emacs && elisp-site-regen
65 }
66
67 pkg_postrm() {
68         use emacs && elisp-site-regen
69 }