Revert DOCTYPE SYSTEM https changes in metadata.xml
[gentoo.git] / dev-haskell / highlighting-kate / highlighting-kate-0.5.6.1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.3.6.9999
8
9 CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
10 inherit haskell-cabal
11
12 DESCRIPTION="Syntax highlighting"
13 HOMEPAGE="https://github.com/jgm/highlighting-kate"
14 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
15
16 LICENSE="GPL-2"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="executable pcre-light"
20
21 RDEPEND=">=dev-haskell/blaze-html-0.4.2:=[profile?] <dev-haskell/blaze-html-0.8:=[profile?]
22         dev-haskell/mtl:=[profile?]
23         dev-haskell/parsec:=[profile?]
24         >=dev-lang/ghc-6.10.4:=
25         pcre-light? ( >=dev-haskell/pcre-light-0.4:=[profile?] <dev-haskell/pcre-light-0.5:=[profile?] )
26         !pcre-light? ( dev-haskell/regex-pcre-builtin:=[profile?] )
27 "
28 DEPEND="${RDEPEND}
29         >=dev-haskell/cabal-1.10
30 "
31
32 src_configure() {
33         haskell-cabal_src_configure \
34                 $(cabal_flag executable executable) \
35                 $(cabal_flag pcre-light pcre-light)
36 }