proj/gentoo: Initial commit
[gentoo.git] / dev-haskell / highlighting-kate / highlighting-kate-0.5.11.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.4.4.9999
8
9 CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal
11
12 DESCRIPTION="Syntax highlighting"
13 HOMEPAGE="http://github.com/jgm/highlighting-kate"
14 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
15
16 LICENSE="GPL-2"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="executable pcre-light"
20
21 RDEPEND=">=dev-haskell/blaze-html-0.4.2:=[profile?] <dev-haskell/blaze-html-0.8:=[profile?]
22         dev-haskell/mtl:=[profile?]
23         dev-haskell/parsec:=[profile?]
24         dev-haskell/utf8-string:=[profile?]
25         >=dev-lang/ghc-7.4.1:=
26         pcre-light? ( >=dev-haskell/pcre-light-0.4:=[profile?] <dev-haskell/pcre-light-0.5:=[profile?] )
27         !pcre-light? ( >=dev-haskell/regex-pcre-builtin-0.94.4.8.8.35:=[profile?] )
28 "
29 DEPEND="${RDEPEND}
30         >=dev-haskell/cabal-1.10
31         test? ( dev-haskell/diff )
32 "
33
34 src_configure() {
35         # SpecConstr OOMs ghc
36         [[ $(ghc-version) == 7.8.* ]] && replace-hcflags -O[2-9] -O1
37
38         haskell-cabal_src_configure \
39                 $(cabal_flag executable executable) \
40                 $(cabal_flag pcre-light pcre-light)
41 }