dev-db/postgresql: Merge "use /bin/sh (...) for postgres user"
[gentoo.git] / dev-haskell / haskeline / haskeline-0.7.1.3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.4.2.9999
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour"
10 inherit haskell-cabal
11
12 DESCRIPTION="A command-line interface for user input, written in Haskell"
13 HOMEPAGE="http://trac.haskell.org/haskeline"
14 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~ppc-macos ~x86-macos"
19 IUSE="legacy-encoding libiconv +terminfo"
20
21 RDEPEND=">=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
22         >=dev-lang/ghc-7.4.1:=
23         legacy-encoding? ( >=dev-haskell/utf8-string-0.3.6:=[profile?] <dev-haskell/utf8-string-0.4:=[profile?] )
24         terminfo? ( >=dev-haskell/terminfo-0.3.1.3:=[profile?] <dev-haskell/terminfo-0.5:=[profile?] )
25 "
26 DEPEND="${RDEPEND}
27         >=dev-haskell/cabal-1.16
28 "
29
30 src_configure() {
31         haskell-cabal_src_configure \
32                 $(cabal_flag legacy-encoding legacy-encoding) \
33                 $(cabal_flag libiconv libiconv) \
34                 $(cabal_flag terminfo terminfo)
35 }