4cd9928d28cd8c6026c21918e557caf846e184b6
[gentoo.git] / dev-haskell / hashtables / hashtables-1.1.2.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.3.4.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour"
9 inherit haskell-cabal
10
11 DESCRIPTION="Mutable hash tables in the ST monad"
12 HOMEPAGE="https://github.com/gregorycollins/hashtables"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 sparc x86"
18 IUSE="bounds-checking portable cpu_flags_x86_sse4_1 +unsafe-tricks"
19
20 RDEPEND="dev-haskell/primitive:=[profile?]
21         >=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.12:=[profile?]
22         >=dev-lang/ghc-6.10.4:=
23         >=dev-haskell/hashable-1.1:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
24 "
25 DEPEND="${RDEPEND}
26         >=dev-haskell/cabal-1.8
27 "
28
29 src_configure() {
30         haskell-cabal_src_configure \
31                 $(cabal_flag bounds-checking bounds-checking) \
32                 $(cabal_flag portable portable) \
33                 $(cabal_flag cpu_flags_x86_sse4_1 sse41) \
34                 $(cabal_flag unsafe-tricks unsafe-tricks)
35 }