Merge remote-tracking branch 'remotes/github/pr/120'.
[gentoo.git] / dev-haskell / hashed-storage / hashed-storage-0.5.11.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.4.9999
8
9 CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
10 inherit haskell-cabal
11
12 DESCRIPTION="Hashed file storage support code"
13 HOMEPAGE="http://hackage.haskell.org/package/hashed-storage"
14 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~ppc-macos ~x86-macos"
19 IUSE="diff hpc test"
20
21 RDEPEND="dev-haskell/binary:=[profile?]
22         dev-haskell/dataenc:=[profile?]
23         dev-haskell/extensible-exceptions:=[profile?]
24         >=dev-haskell/mmap-0.5:=[profile?] <dev-haskell/mmap-0.6:=[profile?]
25         dev-haskell/mtl:=[profile?]
26         dev-haskell/zlib:=[profile?]
27         >=dev-lang/ghc-7.4.1:=
28         diff? ( dev-haskell/lcs:=[profile?] )
29 "
30 DEPEND="${RDEPEND}
31         >=dev-haskell/cabal-1.6
32         test? ( dev-haskell/hunit:=[profile?]
33                 >=dev-haskell/quickcheck-2.3:2=[profile?]
34                 dev-haskell/test-framework:=[profile?]
35                 dev-haskell/test-framework-hunit:=[profile?]
36                 dev-haskell/test-framework-quickcheck2:=[profile?]
37                 dev-haskell/zip-archive:=[profile?] )
38 "
39
40 src_prepare() {
41         epatch "${FILESDIR}"/${P}-ghc-7.10.patch
42 }
43
44 src_configure() {
45         haskell-cabal_src_configure \
46                 $(cabal_flag diff diff) \
47                 $(cabal_flag hpc hpc) \
48                 $(cabal_flag test test)
49 }
50
51 src_install() {
52         haskell-cabal_src_install
53
54         use test && rm "${ED}/usr/bin/hashed-storage-test"
55 }