286ea2c97502c083eb0faa97c1637803465138a8
[gentoo.git] / dev-haskell / gtk2hs-buildtools / gtk2hs-buildtools-0.12.5.1-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.3.5.9999
7
8 CABAL_FEATURES="bin"
9 inherit haskell-cabal
10
11 DESCRIPTION="Tools to build the Gtk2Hs suite of User Interface libraries"
12 HOMEPAGE="http://projects.haskell.org/gtk2hs/"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="GPL-2"
16 SLOT="0/${PV}"
17 KEYWORDS="amd64 ~ia64 ppc ppc64 sparc x86"
18 IUSE="+closuresignals"
19
20 RDEPEND=""
21 DEPEND="${RDEPEND}
22         dev-haskell/alex
23         >=dev-haskell/cabal-1.8
24         dev-haskell/happy
25         dev-haskell/hashtables
26         dev-haskell/random
27         >=dev-lang/ghc-6.10.4
28 "
29
30 src_configure() {
31         haskell-cabal_src_configure \
32                 $(cabal_flag closuresignals closuresignals)
33 }