*/*: dekeyword haskell on ia64
[gentoo.git] / dev-haskell / gtk / gtk-0.14.10-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 # ebuild generated by hackport 0.5.5.9999
7 #hackport: flags: have-gio:gio,-have-quartz-gtk
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour"
10 inherit haskell-cabal
11
12 DESCRIPTION="Binding to the Gtk+ graphical user interface library"
13 HOMEPAGE="http://projects.haskell.org/gtk2hs/"
14 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
15
16 LICENSE="LGPL-2.1"
17 SLOT="2/${PV}"
18 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
19 IUSE="+deprecated +fmode-binary +gio"
20
21 RDEPEND=">=dev-haskell/cairo-0.13.0.0:=[profile?] <dev-haskell/cairo-0.14:=[profile?]
22         >=dev-haskell/glib-0.13.0.0:=[profile?] <dev-haskell/glib-0.14:=[profile?]
23         dev-haskell/mtl:=[profile?]
24         >=dev-haskell/pango-0.13.0.0:=[profile?] <dev-haskell/pango-0.14:=[profile?]
25         >=dev-haskell/text-0.11.0.6:=[profile?] <dev-haskell/text-1.3:=[profile?]
26         >=dev-lang/ghc-7.4.1:=
27         dev-libs/glib:2
28         x11-libs/gtk+:2
29         gio? ( >=dev-haskell/gio-0.13.0:=[profile?] <dev-haskell/gio-0.14:=[profile?] )
30 "
31 DEPEND="${RDEPEND}
32         >=dev-haskell/cabal-1.24 <dev-haskell/cabal-3.1
33         >=dev-haskell/gtk2hs-buildtools-0.13.2.0 <dev-haskell/gtk2hs-buildtools-0.14
34         virtual/pkgconfig
35 "
36
37 src_prepare() {
38         default
39
40         cabal_chdeps \
41                 'Cabal >= 1.24 && < 2.3' 'Cabal >= 1.24 && < 3.1'
42 }
43
44 src_configure() {
45         haskell-cabal_src_configure \
46                 $(cabal_flag deprecated deprecated) \
47                 $(cabal_flag fmode-binary fmode-binary) \
48                 $(cabal_flag gio have-gio) \
49                 --flag=-have-quartz-gtk
50 }