dev-haskell/bytes: bump up to 0.15.5
[gentoo.git] / dev-haskell / glut / glut-2.7.0.15.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 # ebuild generated by hackport 0.6.9999
7 #hackport: flags: -usenativewindowslibraries,buildexamples:examples
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour"
10 inherit haskell-cabal
11
12 MY_PN="GLUT"
13 MY_P="${MY_PN}-${PV}"
14
15 DESCRIPTION="A binding for the OpenGL Utility Toolkit"
16 HOMEPAGE="http://www.haskell.org/haskellwiki/Opengl"
17 SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
18
19 LICENSE="BSD"
20 SLOT="0/${PV}"
21 KEYWORDS="~amd64 ~x86"
22 IUSE="examples"
23
24 RDEPEND=">=dev-haskell/opengl-2.12:=[profile?] <dev-haskell/opengl-3.1:=[profile?]
25         >=dev-haskell/statevar-1.1:=[profile?] <dev-haskell/statevar-1.3:=[profile?]
26         >=dev-lang/ghc-7.8.2:=
27         examples? ( >=dev-haskell/openglraw-1.0:=[profile?] <dev-haskell/openglraw-3.4:=[profile?]
28                         >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.2:=[profile?] )
29 "
30 DEPEND="${RDEPEND}
31         >=dev-haskell/cabal-1.18.1.3
32 "
33
34 S="${WORKDIR}/${MY_P}"
35
36 src_configure() {
37         haskell-cabal_src_configure \
38                 $(cabal_flag examples buildexamples) \
39                 --flag=-usenativewindowslibraries
40 }