dev-qt/qtscript: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-haskell / glib / glib-0.13.4.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # ebuild generated by hackport 0.5.3.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour"
9 inherit haskell-cabal
10
11 DESCRIPTION="Binding to the GLIB library for Gtk2Hs"
12 HOMEPAGE="http://projects.haskell.org/gtk2hs/"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="LGPL-2.1"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
18 IUSE="+closure-signals"
19
20 RDEPEND=">=dev-haskell/text-1.0.0.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
21         >=dev-haskell/utf8-string-0.2:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
22         >=dev-lang/ghc-7.4.1:=
23         dev-libs/glib:2
24 "
25 DEPEND="${RDEPEND}
26         >=dev-haskell/cabal-1.24 <dev-haskell/cabal-1.25
27         >=dev-haskell/gtk2hs-buildtools-0.13.2.0 <dev-haskell/gtk2hs-buildtools-0.14
28         virtual/pkgconfig
29 "
30
31 src_configure() {
32         haskell-cabal_src_configure \
33                 $(cabal_flag closure-signals closure_signals)
34 }