dev-haskell/edisonapi: bump up to 1.3.1-r1
[gentoo.git] / dev-haskell / filestore / filestore-0.6.3.4.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 # ebuild generated by hackport 0.6.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="Interface for versioning file stores"
12 HOMEPAGE="http://hackage.haskell.org/package/filestore"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="+maxcount"
19
20 RDEPEND=">=dev-haskell/diff-0.2:=[profile?] <dev-haskell/diff-0.4:=[profile?]
21         >=dev-haskell/old-locale-1.0:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
22         >=dev-haskell/parsec-2:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
23         >=dev-haskell/split-0.1:=[profile?] <dev-haskell/split-0.3:=[profile?]
24         >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
25         >=dev-haskell/xml-1.3:=[profile?] <dev-haskell/xml-1.4:=[profile?]
26         >=dev-lang/ghc-7.4.1:=
27 "
28 DEPEND="${RDEPEND}
29         >=dev-haskell/cabal-1.10
30         test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.7
31                 dev-haskell/mtl )
32 "
33
34 src_configure() {
35         haskell-cabal_src_configure \
36                 $(cabal_flag maxcount maxcount)
37 }