dev-haskell/edisonapi: bump up to 1.3.1-r1
[gentoo.git] / dev-haskell / filestore / filestore-0.6.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.5.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="Interface for versioning file stores"
12 HOMEPAGE="http://hackage.haskell.org/package/filestore"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="+maxcount"
19
20 RESTRICT=test # one darcs test fails
21
22 RDEPEND=">=dev-haskell/diff-0.2:=[profile?] <dev-haskell/diff-0.4:=[profile?]
23         >=dev-haskell/old-locale-1.0:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
24         >=dev-haskell/parsec-2:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
25         >=dev-haskell/split-0.1:=[profile?] <dev-haskell/split-0.3:=[profile?]
26         >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
27         >=dev-haskell/xml-1.3:=[profile?] <dev-haskell/xml-1.4:=[profile?]
28         >=dev-lang/ghc-7.4.1:=
29 "
30 DEPEND="${RDEPEND}
31         >=dev-haskell/cabal-1.10
32         test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.3
33                 dev-haskell/mtl )
34 "
35 DEPEND+="
36         test? ( dev-vcs/darcs
37                 dev-vcs/git
38                 dev-vcs/mercurial
39         )
40 "
41
42 src_prepare() {
43         epatch "${FILESDIR}"/${P}-ghc-8.patch
44
45         cabal_chdeps \
46                 'time >= 1.1 && < 1.6' 'time >= 1.1' \
47                 'process >= 1.0 && < 1.3' 'process >= 1.0'
48 }
49
50 src_configure() {
51         haskell-cabal_src_configure \
52                 $(cabal_flag maxcount maxcount)
53 }
54
55 src_test() {
56         export HOME=${T}/
57         git config --global user.email "git@src_test"
58         git config --global user.name "Mr. ${P} The Test"
59
60         haskell-cabal_src_test
61 }