Merge remote-tracking branch 'remotes/github/pr/662'
[gentoo.git] / dev-haskell / feed / feed-0.3.9.2-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.3.4.9999
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour"
10 inherit haskell-cabal
11
12 DESCRIPTION="Interfacing with RSS (v 0.9x, 2.x, 1.0) + Atom feeds"
13 HOMEPAGE="https://github.com/sof/feed"
14 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 RDEPEND="dev-haskell/utf8-string:=[profile?]
22         >=dev-haskell/xml-1.2.6:=[profile?]
23         >=dev-lang/ghc-6.12.1:=
24 "
25 DEPEND="${RDEPEND}
26         >=dev-haskell/cabal-1.8.0.2
27 "
28
29 src_prepare() {
30         epatch "${FILESDIR}"/"${P}"-utf8-string.patch
31         epatch "${FILESDIR}"/"${P}"-ghc-7.10.patch
32 }