proj/gentoo: Initial commit
[gentoo.git] / dev-haskell / email-validate / email-validate-1.0.0.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.3.2.9999
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal
11
12 DESCRIPTION="Validating an email address string against RFC 5322"
13 HOMEPAGE="http://porg.es/blog/email-address-validation-simpler-faster-more-correct"
14 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 RDEPEND=">=dev-haskell/attoparsec-0.10.0:=[profile?]
22                 >=dev-lang/ghc-6.10.4:="
23 DEPEND="${RDEPEND}
24                 test? ( >=dev-haskell/hunit-1.2
25                         <dev-haskell/hunit-2
26                         >=dev-haskell/quickcheck-2.4
27                         >=dev-haskell/test-framework-0.4.1
28                         dev-haskell/test-framework-hunit
29                         dev-haskell/test-framework-quickcheck2
30                 )
31                 >=dev-haskell/cabal-1.8"