dev-qt/qtscript: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-haskell / ed25519 / ed25519-0.0.5.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # ebuild generated by hackport 0.4.6.9999
7 #hackport: flags: +no-donna,+test-doctests,+test-properties,-test-hlint
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal
11
12 DESCRIPTION="Ed25519 cryptographic signatures"
13 HOMEPAGE="http://thoughtpolice.github.com/hs-ed25519"
14 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 RDEPEND=">=dev-lang/ghc-7.4.1:=
22 "
23 DEPEND="${RDEPEND}
24         >=dev-haskell/cabal-1.10
25         test? ( >=dev-haskell/doctest-0.10
26                 >=dev-haskell/quickcheck-2.4 )
27 "
28
29 src_prepare() {
30         default
31
32         cabal_chdeps \
33                 'ghc-prim    >= 0.1 && < 0.5' 'ghc-prim    >= 0.1' \
34                 'doctest   >= 0.10 && < 0.11' 'doctest   >= 0.10' \
35                 'QuickCheck  >= 2.4 && < 2.9' 'QuickCheck  >= 2.4' \
36                 'directory >= 1.0  && < 1.3' 'directory >= 1.0'
37 }
38
39 src_configure() {
40         haskell-cabal_src_configure \
41                 --flag=no-donna \
42                 --flag=test-doctests \
43                 --flag=-test-hlint \
44                 --flag=test-properties
45 }