dev-haskell/bytes: bump up to 0.15.5
[gentoo.git] / dev-haskell / dbus-core / dbus-core-0.9.3-r3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.3.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour"
9 inherit haskell-cabal
10
11 DESCRIPTION="Low-level D-Bus protocol implementation"
12 HOMEPAGE="https://john-millikin.com/software/dbus-core/"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="GPL-3"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RDEPEND=">=dev-haskell/binary-0.4:=[profile?]
21                 >=dev-haskell/data-binary-ieee754-0.3:=[profile?] <dev-haskell/data-binary-ieee754-0.5:=[profile?]
22                 =dev-haskell/libxml-sax-0.7*:=[profile?]
23                 >=dev-haskell/network-2.2:=[profile?]
24                 >=dev-haskell/parsec-2.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
25                 >=dev-haskell/text-0.11.1.5:=[profile?]
26                 >=dev-haskell/vector-0.7:=[profile?]
27                 =dev-haskell/xml-types-0.3*:=[profile?]
28                 >=dev-lang/ghc-6.10.4:="
29 DEPEND="${RDEPEND}
30                 >=dev-haskell/cabal-1.6"
31
32 src_prepare() {
33         epatch "${FILESDIR}"/${P}-ghc-7.10.patch
34
35         if has_version "<dev-haskell/haddock-2.9.2"; then
36                 # Workaround http://hackage.haskell.org/trac/hackage/ticket/626
37                 # The haddock --hoogle option does not like unicode characters, which causes
38                 # haddock 2.7.2 to fail like:
39                 # haddock: internal Haddock or GHC error: dist/doc/html/enumerator/enumerator.txt: commitAndReleaseBuffer: invalid argument (Invalid or incomplete multibyte or wide character)
40                 sed -e 's@&#8208;@-@g' \
41                         -e "s@&#8217;@'@g" \
42                         -i "${S}/hs/DBus/Connection.hs" \
43                         -i "${S}/hs/DBus/Client/Internal.hs" \
44                         -i "${S}/hs/DBus/Client/Simple.hs" \
45                         -i "${S}/hs/DBus/Message/Internal.hs" \
46                         -i "${S}/hs/DBus/Types/Internal.hs" \
47                         -i "${S}/hs/DBus/Wire/Internal.hs"
48         fi
49         cabal_chdeps \
50                 'binary >= 0.4 && < 0.6' 'binary >= 0.4' \
51                 'bytestring >= 0.9 && < 0.10' 'bytestring >= 0.9' \
52                 'containers >= 0.1 && < 0.5' 'containers >= 0.1' \
53                 'network >= 2.2 && < 2.4' 'network >= 2.2' \
54                 'text >= 0.11.1.5 && < 0.12' 'text >= 0.11.1.5' \
55                 'unix >= 2.2 && < 2.6' 'unix >= 2.2' \
56                 'vector >= 0.7 && < 0.10' 'vector >= 0.7'
57 }