Drop $Id$ per council decision in bug #611234.
[gentoo.git] / dev-haskell / dbus / dbus-0.10.12.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.7.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="A client library for the D-Bus IPC system"
12 HOMEPAGE="https://john-millikin.com/software/haskell-dbus/"
13 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
14
15 LICENSE="GPL-3"
16 SLOT="0/${PV}"
17 KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
18 IUSE=""
19
20 RDEPEND=">=dev-haskell/cereal-0.3.4:=[profile?] <dev-haskell/cereal-0.6:=[profile?]
21         >=dev-haskell/libxml-sax-0.7:=[profile?] <dev-haskell/libxml-sax-0.8:=[profile?]
22         >=dev-haskell/network-2.2.3:=[profile?]
23         >=dev-haskell/parsec-2.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
24         >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-2.0:=[profile?]
25         >=dev-haskell/text-0.11.1.5:=[profile?]
26         >=dev-haskell/transformers-0.2:=[profile?]
27         >=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.12:=[profile?]
28         >=dev-haskell/xml-types-0.3:=[profile?] <dev-haskell/xml-types-0.4:=[profile?]
29         >=dev-lang/ghc-7.8.2:=
30 "
31 DEPEND="${RDEPEND}
32         >=dev-haskell/cabal-1.18.1.3
33         test? ( >=dev-haskell/chell-0.4 <dev-haskell/chell-0.5
34                 >=dev-haskell/chell-quickcheck-0.2 <dev-haskell/chell-quickcheck-0.3
35                 >=dev-haskell/quickcheck-2.4 )
36 "
37
38 src_prepare() {
39         epatch "${FILESDIR}"/${P}-QC-2.8.2.patch
40 }