dev-haskell/syb: bump up to 0.7.1
[gentoo.git] / dev-haskell / dav / dav-1.3.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # ebuild generated by hackport 0.5.9999
7 #hackport: flags: -mtl-compat
8
9 CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
10 inherit haskell-cabal
11
12 MY_PN="DAV"
13 MY_P="${MY_PN}-${PV}"
14
15 DESCRIPTION="RFC 4918 WebDAV support"
16 HOMEPAGE="http://floss.scru.org/hDAV"
17 SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
18
19 LICENSE="GPL-3"
20 SLOT="0/${PV}"
21 KEYWORDS="~amd64 ~x86"
22 IUSE="+network-uri"
23
24 RDEPEND=">=dev-haskell/case-insensitive-0.4:=[profile?]
25         dev-haskell/data-default:=[profile?]
26         >=dev-haskell/exceptions-0.7:=[profile?]
27         dev-haskell/haskeline:=[profile?]
28         >=dev-haskell/http-client-0.4:=[profile?]
29         >=dev-haskell/http-client-tls-0.2:=[profile?]
30         >=dev-haskell/http-types-0.7:=[profile?]
31         >=dev-haskell/lens-3.0:=[profile?]
32         >=dev-haskell/mtl-2.2.1:=[profile?]
33         >=dev-haskell/optparse-applicative-0.10.0:=[profile?]
34         dev-haskell/transformers-base:=[profile?]
35         >=dev-haskell/transformers-compat-0.3:=[profile?]
36         dev-haskell/utf8-string:=[profile?]
37         >=dev-haskell/xml-conduit-1.0:=[profile?]
38         >=dev-haskell/xml-hamlet-0.4:=[profile?] <dev-haskell/xml-hamlet-0.5:=[profile?]
39         >=dev-lang/ghc-7.8.2:=
40         network-uri? ( >=dev-haskell/network-2.6:=[profile?]
41                         >=dev-haskell/network-uri-2.6:=[profile?] )
42         !network-uri? ( >=dev-haskell/network-2.3:=[profile?] <dev-haskell/network-2.6:=[profile?] )
43 "
44 DEPEND="${RDEPEND}
45         >=dev-haskell/cabal-1.18.1.3
46 "
47
48 S="${WORKDIR}/${MY_P}"
49
50 src_configure() {
51         haskell-cabal_src_configure \
52                 --flag=-mtl-compat \
53                 $(cabal_flag network-uri network-uri)
54 }