dev-haskell/syb: bump up to 0.7.1
[gentoo.git] / dev-haskell / dav / dav-0.5.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.3.5.9999
7
8 CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
9 inherit haskell-cabal
10
11 MY_PN="DAV"
12 MY_P="${MY_PN}-${PV}"
13
14 DESCRIPTION="RFC 4918 WebDAV support"
15 HOMEPAGE="http://floss.scru.org/hDAV"
16 SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
17
18 LICENSE="GPL-3"
19 SLOT="0/${PV}"
20 KEYWORDS="~amd64 ~x86"
21 IUSE=""
22
23 RDEPEND=">=dev-haskell/case-insensitive-0.4:=[profile?]
24         >=dev-haskell/http-client-0.2:=[profile?]
25         >=dev-haskell/http-client-tls-0.2:=[profile?]
26         >=dev-haskell/http-types-0.7:=[profile?]
27         >=dev-haskell/lens-3.0:=[profile?]
28         >=dev-haskell/lifted-base-0.1:=[profile?]
29         >=dev-haskell/mtl-2.1:=[profile?]
30         >=dev-haskell/network-2.3:=[profile?]
31         dev-haskell/optparse-applicative:=[profile?]
32         >=dev-haskell/resourcet-0.3:=[profile?]
33         >=dev-haskell/transformers-0.3:=[profile?]
34         >=dev-haskell/xml-conduit-1.0:=[profile?] <=dev-haskell/xml-conduit-1.2:=[profile?]
35         >=dev-haskell/xml-hamlet-0.4:=[profile?] <=dev-haskell/xml-hamlet-0.5:=[profile?]
36         >=dev-lang/ghc-7.4.1:=
37 "
38 DEPEND="${RDEPEND}
39         >=dev-haskell/cabal-1.8
40 "
41
42 S="${WORKDIR}/${MY_P}"