43b3d68e0bb558ab3c1b33d2f944bd6b92fd3f67
[gentoo.git] / dev-haskell / dataenc / dataenc-0.14.0.7.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.9999
7
8 CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
9 inherit haskell-cabal
10
11 DESCRIPTION="Data encoding library"
12 HOMEPAGE="http://www.haskell.org/haskellwiki/Library/Data_encoding"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x86-macos"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 RDEPEND=">=dev-lang/ghc-7.4.1:=
22 "
23 DEPEND="${RDEPEND}
24         >=dev-haskell/cabal-1.6
25         test? ( dev-haskell/hunit:=[profile?]
26                         >=dev-haskell/quickcheck-2.5:2=[profile?]
27                         dev-haskell/test-framework:=[profile?]
28                         dev-haskell/test-framework-hunit:=[profile?]
29                         dev-haskell/test-framework-quickcheck2:=[profile?]
30                         dev-haskell/test-framework-th:=[profile?] )
31 "
32
33 src_prepare() {
34         cabal_chdeps \
35                 'base >= 3.0.0 && < 4.8' 'base >= 3.0.0' \
36                 'QuickCheck ==2.5.*' 'QuickCheck >=2.5' \
37                 'executable tests' 'executable dataenc-tests'
38 }
39
40 src_configure() {
41         haskell-cabal_src_configure \
42                 $(cabal_flag test tests)
43 }