dev-haskell/edisonapi: bump up to 1.3.1-r1
[gentoo.git] / dev-haskell / cryptohash / cryptohash-0.9.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.3.2.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="collection of crypto hashes, fast, pure and practical"
12 HOMEPAGE="https://github.com/vincenthz/hs-cryptohash"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="+cryptoapi"
19
20 RDEPEND="dev-haskell/byteable:=[profile?]
21                 >=dev-lang/ghc-6.10.4:=
22                 cryptoapi? ( >=dev-haskell/cereal-0.2:=[profile?]
23                         >=dev-haskell/crypto-api-0.5:=[profile?]
24                         >=dev-haskell/tagged-0.1:=[profile?]
25                 )"
26 DEPEND="${RDEPEND}
27                 >=dev-haskell/cabal-1.8
28                 test? ( dev-haskell/hunit
29                         >=dev-haskell/quickcheck-2
30                         >=dev-haskell/test-framework-0.3.3
31                         dev-haskell/test-framework-hunit
32                         >=dev-haskell/test-framework-quickcheck2-0.2.9
33                 )"
34
35 src_configure() {
36         haskell-cabal_src_configure \
37                 $(cabal_flag cryptoapi cryptoapi)
38 }