Merge remote-tracking branch 'remotes/Coacher/mpv-verbump-to-0.15.0'
[gentoo.git] / dev-haskell / crypto-conduit / crypto-conduit-0.5.5-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.4.4.9999
8 #hackport: flags: -old-crypto-api
9
10 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
11 inherit haskell-cabal
12
13 DESCRIPTION="Conduit interface for cryptographic operations (from crypto-api)"
14 HOMEPAGE="https://github.com/prowdsponsor/crypto-conduit"
15 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
16
17 LICENSE="BSD"
18 SLOT="0/${PV}"
19 KEYWORDS="~amd64 ~x86"
20 IUSE="+conduit11"
21
22 RDEPEND=">=dev-haskell/cereal-0.3:=[profile?]
23         >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
24         >=dev-haskell/crypto-api-0.9:=[profile?] <dev-haskell/crypto-api-0.14:=[profile?]
25         dev-haskell/resourcet:=[profile?]
26         >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
27         >=dev-lang/ghc-7.4.1:=
28         conduit11? ( >=dev-haskell/conduit-extra-1.1:=[profile?] )
29 "
30 DEPEND="${RDEPEND}
31         >=dev-haskell/cabal-1.8
32         test? ( >=dev-haskell/crypto-api-0.13
33                 >=dev-haskell/cryptocipher-0.4
34                 >=dev-haskell/cryptohash-cryptoapi-0.1
35                 >=dev-haskell/hspec-1.3
36                 >=dev-haskell/skein-0.1 )
37 "
38
39 src_prepare() {
40         cabal_chdeps \
41                 'cereal       >= 0.3 && < 0.5' 'cereal       >= 0.3'
42 }
43
44 src_configure() {
45         haskell-cabal_src_configure \
46                 $(cabal_flag conduit11 conduit11) \
47                 --flag=-old-crypto-api
48 }