Merge remote-tracking branch 'jirutka/lxc-grsec'
[gentoo.git] / dev-haskell / crypto-api / crypto-api-0.13.2.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.4.3.9999
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour"
10 inherit haskell-cabal
11
12 DESCRIPTION="A generic interface for cryptographic operations"
13 HOMEPAGE="https://github.com/TomMD/crypto-api"
14 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="~alpha amd64 ~ia64 x86"
19 IUSE="all_cpolys"
20
21 RDEPEND=">=dev-haskell/cereal-0.2:=[profile?]
22         dev-haskell/entropy:=[profile?]
23         >=dev-haskell/tagged-0.1:=[profile?]
24         dev-haskell/transformers:=[profile?]
25         >=dev-lang/ghc-7.4.1:=
26 "
27 DEPEND="${RDEPEND}
28         >=dev-haskell/cabal-1.6
29 "
30
31 src_configure() {
32         haskell-cabal_src_configure \
33                 $(cabal_flag all_cpolys all_cpolys)
34 }