sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / dev-haskell / cmdargs / cmdargs-0.10.13.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.5.9999
7
8 CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
9 inherit haskell-cabal
10
11 DESCRIPTION="Command line argument processing"
12 HOMEPAGE="http://community.haskell.org/~ndm/cmdargs/"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="+quotation testprog"
19
20 RDEPEND=">=dev-haskell/transformers-0.2:=[profile?]
21         >=dev-lang/ghc-7.4.1:=
22 "
23 DEPEND="${RDEPEND}
24         >=dev-haskell/cabal-1.6
25 "
26
27 src_configure() {
28         haskell-cabal_src_configure \
29                 $(cabal_flag quotation quotation) \
30                 $(cabal_flag testprog testprog)
31 }