Merge remote-tracking branch 'github/pr/703'. Fixes bug 560362.
[gentoo.git] / dev-haskell / classy-prelude / classy-prelude-0.5.8.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.3.2.9999
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal
11
12 DESCRIPTION="A typeclass-based Prelude"
13 HOMEPAGE="https://github.com/snoyberg/classy-prelude"
14 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 RDEPEND=">=dev-haskell/basic-prelude-0.3.4:=[profile?]
22                 <dev-haskell/basic-prelude-0.4:=[profile?]
23                 dev-haskell/hashable:=[profile?]
24                 >=dev-haskell/lifted-base-0.2:=[profile?]
25                 dev-haskell/monad-control:=[profile?]
26                 =dev-haskell/system-filepath-0.4*:=[profile?]
27                 dev-haskell/text:=[profile?]
28                 dev-haskell/transformers:=[profile?]
29                 dev-haskell/unordered-containers:=[profile?]
30                 dev-haskell/vector:=[profile?]
31                 >=dev-lang/ghc-7.4.1:="
32 DEPEND="${RDEPEND}
33                 >=dev-haskell/cabal-1.8
34                 test? ( >=dev-haskell/hspec-1.3
35                         dev-haskell/quickcheck
36                 )"