proj/gentoo: Initial commit
[gentoo.git] / dev-haskell / chasingbottoms / chasingbottoms-1.3.0.7.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.3.4.9999
8
9 CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
10 inherit haskell-cabal
11
12 MY_PN="ChasingBottoms"
13 MY_P="${MY_PN}-${PV}"
14
15 DESCRIPTION="For testing partial and infinite values"
16 HOMEPAGE="http://hackage.haskell.org/package/ChasingBottoms"
17 SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
18
19 LICENSE="MIT"
20 SLOT="0/${PV}"
21 KEYWORDS="amd64 x86"
22 IUSE="test"
23
24 RDEPEND=">=dev-haskell/mtl-1.1:=[profile?] <dev-haskell/mtl-2.2:=[profile?]
25         >=dev-haskell/quickcheck-2.1:=[profile?] <dev-haskell/quickcheck-2.7:=[profile?]
26         >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.1:=[profile?]
27         >=dev-haskell/syb-0.1.0.2:=[profile?] <dev-haskell/syb-0.5:=[profile?]
28         >=dev-lang/ghc-6.12.1:=
29 "
30 DEPEND="${RDEPEND}
31         >=dev-haskell/cabal-1.8.0.2
32 "
33
34 S="${WORKDIR}/${MY_P}"
35
36 src_configure() {
37         haskell-cabal_src_configure \
38                 $(cabal_flag test build-tests)
39 }