dev-haskell/bytes: bump up to 0.15.5
[gentoo.git] / dev-haskell / bloomfilter / bloomfilter-1.2.6.10-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.2.18.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit eutils haskell-cabal
10
11 DESCRIPTION="Pure and impure Bloom Filter implementations"
12 HOMEPAGE="https://github.com/bos/bloomfilter"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86 ~amd64-linux"
18 IUSE=""
19
20 RDEPEND=">=dev-lang/ghc-6.8.2:="
21 DEPEND="${RDEPEND}
22                 test? ( >=dev-haskell/quickcheck-2.4:2
23                         <dev-haskell/quickcheck-2.8:2
24                         dev-haskell/random
25                         dev-haskell/test-framework
26                         dev-haskell/test-framework-quickcheck2
27                 )
28                 >=dev-haskell/cabal-1.8"
29
30 src_prepare() {
31         cabal_chdeps \
32                 'QuickCheck == 2.4.*' 'QuickCheck >= 2.4 && < 2.8'
33
34         if has_version ">=dev-haskell/quickcheck-2.5"; then
35                 epatch "${FILESDIR}/${PN}-1.2.6.10-quickcheck-2.6.patch"
36         fi
37         epatch "${FILESDIR}/${PN}-1.2.6.10-ghc-7.7.patch"
38 }