*/*: Drop stable ia64 keywords
[gentoo.git] / dev-haskell / bits-atomic / bits-atomic-0.1.3-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.6.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="Atomic bit operations on memory locations for low-level synchronization"
12 HOMEPAGE="http://hackage.haskell.org/package/bits-atomic"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
14         https://dev.gentoo.org/~slyfox/patches/${P}-gcc-5.patch"
15
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 RDEPEND=">=dev-lang/ghc-7.4.1:=
22 "
23 DEPEND="${RDEPEND}
24         >=dev-haskell/cabal-1.8
25         test? ( dev-haskell/hunit
26                 dev-haskell/quickcheck
27                 dev-haskell/test-framework
28                 dev-haskell/test-framework-hunit
29                 dev-haskell/test-framework-quickcheck2 )
30 "
31
32 src_prepare() {
33         epatch "${DISTDIR}"/${P}-gcc-5.patch
34         epatch "${FILESDIR}"/${P}-ghc-8.patch
35 }