dev-haskell/attoparsec: amd64, x86 stable, bug #559988
[gentoo.git] / dev-haskell / attoparsec / attoparsec-0.13.0.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.4.5.9999
8 #hackport: flags: -developer
9
10 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
11 inherit haskell-cabal
12
13 DESCRIPTION="Fast combinator parsing for bytestrings and text"
14 HOMEPAGE="https://github.com/bos/attoparsec"
15 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
16
17 LICENSE="BSD"
18 SLOT="0/${PV}"
19 KEYWORDS="amd64 x86"
20 IUSE=""
21
22 RDEPEND=">=dev-haskell/scientific-0.3.1:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
23         >=dev-haskell/text-1.1.1.3:=[profile?]
24         dev-haskell/transformers:=[profile?]
25         >=dev-lang/ghc-7.4.1:=
26 "
27 DEPEND="${RDEPEND}
28         >=dev-haskell/cabal-1.8
29         test? ( >=dev-haskell/quickcheck-2.7
30                 dev-haskell/quickcheck-unicode
31                 >=dev-haskell/test-framework-0.8.0.2
32                 >=dev-haskell/test-framework-quickcheck2-0.3.0.3
33                 dev-haskell/vector )
34 "
35
36 src_configure() {
37         haskell-cabal_src_configure \
38                 --flag=-developer
39 }