dev-libs/tomsfastmath: keyworded 0.13.1 for ppc, bug #725414
[gentoo.git] / dev-haskell / atomic-primops / atomic-primops-0.8.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 # ebuild generated by hackport 0.6.1
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour"
9 inherit haskell-cabal
10
11 DESCRIPTION="A safe approach to CAS and other atomic ops in Haskell"
12 HOMEPAGE="https://github.com/rrnewton/haskell-lockfree/wiki"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="debug"
19
20 RDEPEND="dev-haskell/primitive:=[profile?]
21         >=dev-lang/ghc-7.10.1:=
22 "
23 DEPEND="${RDEPEND}
24         >=dev-haskell/cabal-1.22.2.0
25 "
26
27 src_configure() {
28         haskell-cabal_src_configure \
29                 $(cabal_flag debug debug)
30 }