dev-libs/tomsfastmath: keyworded 0.13.1 for ppc, bug #725414
[gentoo.git] / dev-haskell / atomic-primops / atomic-primops-0.4-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.3.2.9999
7
8 CABAL_FEATURES="lib haddock hoogle hscolour profile"
9 inherit haskell-cabal
10
11 DESCRIPTION="A safe approach to CAS and other atomic ops in Haskell"
12 HOMEPAGE="https://github.com/rrnewton/haskell-lockfree-queue/wiki"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="debug"
19
20 RDEPEND="dev-haskell/bits-atomic:=[profile?]
21                 dev-haskell/cabal:=[profile?]
22                 dev-haskell/primitive:=[profile?]
23                 >=dev-lang/ghc-7.4.1:="
24 DEPEND="${RDEPEND}
25                 profile? ( !<dev-haskell/cabal-1.17 )
26                 >=dev-haskell/cabal-1.8"
27
28 src_configure() {
29         haskell-cabal_src_configure \
30                 $(cabal_flag debug debug)
31 }