dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-haskell / arithmoi / arithmoi-0.4.3.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # ebuild generated by hackport 0.5.9999
7 #hackport: flags: -check-bounds
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal
11
12 DESCRIPTION="Efficient basic number-theoretic functions. Primes, powers, integer logarithms"
13 HOMEPAGE="https://github.com/cartazio/arithmoi"
14 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 RDEPEND=">=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
22         >=dev-haskell/nats-1:=[profile?] <dev-haskell/nats-1.2:=[profile?]
23         >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.2:=[profile?]
24         >=dev-haskell/semigroups-0.8:=[profile?]
25         >=dev-lang/ghc-7.8.2:=
26 "
27 DEPEND="${RDEPEND}
28         >=dev-haskell/cabal-1.18.1.3
29         test? ( >=dev-haskell/quickcheck-2.7.6 <dev-haskell/quickcheck-2.10
30                 >=dev-haskell/smallcheck-1.1 <dev-haskell/smallcheck-1.2
31                 >=dev-haskell/tasty-0.10 <dev-haskell/tasty-0.12
32                 >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.10
33                 >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.9
34                 >=dev-haskell/tasty-smallcheck-0.8 <dev-haskell/tasty-smallcheck-0.9
35                 >=dev-haskell/transformers-compat-0.4 )
36 "
37
38 src_configure() {
39         haskell-cabal_src_configure \
40                 --flag=-check-bounds
41 }