dev-libs/tomsfastmath: keyworded 0.13.1 for ppc, bug #725414
[gentoo.git] / dev-haskell / alut / alut-2.4.0.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 # ebuild generated by hackport 0.6.9999
7 #hackport: flags: -usenativewindowslibraries,buildexamples:examples
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour"
10 inherit haskell-cabal
11
12 MY_PN="ALUT"
13 MY_P="${MY_PN}-${PV}"
14
15 DESCRIPTION="A binding for the OpenAL Utility Toolkit"
16 HOMEPAGE="https://github.com/haskell-openal/ALUT"
17 SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
18
19 LICENSE="BSD"
20 SLOT="0/${PV}"
21 KEYWORDS="~amd64 ~x86"
22 IUSE="examples"
23
24 RDEPEND=">=dev-haskell/openal-1.7:=[profile?] <dev-haskell/openal-1.8:=[profile?]
25         >=dev-haskell/statevar-1.1:=[profile?] <dev-haskell/statevar-1.3:=[profile?]
26         >=dev-lang/ghc-7.8.2:=
27         media-libs/freealut
28 "
29 DEPEND="${RDEPEND}
30         >=dev-haskell/cabal-1.18.1.3
31 "
32
33 S="${WORKDIR}/${MY_P}"
34
35 src_configure() {
36         haskell-cabal_src_configure \
37                 $(cabal_flag examples buildexamples) \
38                 --flag=-usenativewindowslibraries
39 }