dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-haskell / aeson / aeson-1.0.2.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # ebuild generated by hackport 0.5.9999
7 #hackport: flags: -developer,-fast
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal
11
12 DESCRIPTION="Fast JSON parsing and encoding"
13 HOMEPAGE="https://github.com/bos/aeson"
14 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 RDEPEND=">=dev-haskell/attoparsec-0.13.0.1:=[profile?]
22         >=dev-haskell/base-compat-0.9.1:=[profile?] <dev-haskell/base-compat-0.10:=[profile?]
23         >=dev-haskell/dlist-0.2:=[profile?]
24         >=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
25         >=dev-haskell/hashable-1.1.2.0:=[profile?]
26         >=dev-haskell/nats-1:=[profile?] <dev-haskell/nats-1.2:=[profile?]
27         >=dev-haskell/scientific-0.3.4.7:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
28         >=dev-haskell/semigroups-0.18.2:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
29         >=dev-haskell/tagged-0.8.3:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
30         >=dev-haskell/text-1.1.1.0:=[profile?]
31         >=dev-haskell/time-locale-compat-0.1.1:=[profile?] <dev-haskell/time-locale-compat-0.2:=[profile?]
32         >=dev-haskell/transformers-compat-0.3:=[profile?]
33         >=dev-haskell/unordered-containers-0.2.5.0:=[profile?]
34         >=dev-haskell/vector-0.8:=[profile?]
35         >=dev-lang/ghc-7.8.2:=
36 "
37 DEPEND="${RDEPEND}
38         >=dev-haskell/cabal-1.18.1.3
39         test? ( >=dev-haskell/base-orphans-0.5.3 <dev-haskell/base-orphans-0.6
40                 dev-haskell/base16-bytestring
41                 >=dev-haskell/generic-deriving-1.10 <dev-haskell/generic-deriving-1.12
42                 >=dev-haskell/hashable-1.2.4.0
43                 >=dev-haskell/hashable-time-0.2 <dev-haskell/hashable-time-0.3
44                 dev-haskell/hunit
45                 >=dev-haskell/quickcheck-2.7 <dev-haskell/quickcheck-2.9.3
46                 >=dev-haskell/quickcheck-instances-0.3.12
47                 dev-haskell/test-framework
48                 dev-haskell/test-framework-hunit
49                 dev-haskell/test-framework-quickcheck2 )
50 "
51
52 src_configure() {
53         haskell-cabal_src_configure \
54                 --flag=-developer \
55                 --flag=-fast
56 }