674e71cc05c1f001e3116644c1f9f50c6b31bb78
[gentoo.git] / dev-go / go-protobuf / go-protobuf-0_pre20150809.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 EGO_SRC=github.com/golang/protobuf
7 EGO_PN=${EGO_SRC}/...
8
9 if [[ ${PV} = *9999* ]]; then
10         inherit golang-vcs
11 else
12         KEYWORDS="~amd64"
13         EGIT_COMMIT="68c687dc49948540b356a6b47931c9be4fcd0245"
14         SRC_URI="https://${EGO_SRC}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
15         inherit golang-vcs-snapshot
16 fi
17 inherit golang-build
18
19 DESCRIPTION="Go support for Google's protocol buffers"
20 HOMEPAGE="https://${EGO_SRC}"
21 LICENSE="BSD"
22 SLOT="0/${PV}"
23 IUSE=""
24 DEPEND=""
25 RDEPEND=""
26
27 src_install() {
28         rm -rf src/${EGO_SRC}/.git* || die
29         golang-build_src_install
30         dobin bin/*
31 }