dev-ruby/rex-text: cleanup
[gentoo.git] / dev-go / go-oauth2 / go-oauth2-9999.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 EGO_PN=golang.org/x/oauth2
7 EGO_SRC=golang.org/x/oauth2
8
9 if [[ ${PV} = *9999* ]]; then
10         inherit golang-vcs
11 else
12         KEYWORDS="~amd64"
13         EGIT_COMMIT="b5adcc2dcdf009d0391547edc6ecbaff889f5bb9"
14         SRC_URI="https://github.com/golang/oauth2/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
15         inherit golang-vcs-snapshot
16 fi
17 inherit golang-build
18
19 DESCRIPTION="Go client implementation for OAuth 2.0 spec"
20 HOMEPAGE="https://godoc.org/golang.org/x/oauth2"
21
22 LICENSE="BSD"
23 SLOT="0/${PV}"
24 IUSE=""
25
26 DEPEND="
27         dev-go/go-net:=
28         dev-go/go-tools:="
29 RDEPEND=""