dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-go / go-eapache-queue / go-eapache-queue-1.0.2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 EGO_SRC=github.com/eapache/queue
7 EGO_PN=${EGO_SRC}/...
8
9 if [[ ${PV} = *9999* ]]; then
10         inherit golang-vcs
11 else
12         KEYWORDS="~amd64"
13         SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
14         inherit golang-vcs-snapshot
15 fi
16 inherit golang-build
17
18 DESCRIPTION="Fast golang queue using ring-buffer"
19 HOMEPAGE="https://github.com/eapache/queue"
20 LICENSE="MIT"
21 SLOT="0/${PV}"
22 IUSE=""
23 DEPEND=""
24 RDEPEND=""