dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-games / t4k-common / t4k-common-0.1.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils ltprune
6
7 DESCRIPTION="A library of code shared between tuxmath and tuxtype"
8 HOMEPAGE="https://github.com/tux4kids/t4kcommon"
9 SRC_URI="https://github.com/tux4kids/t4kcommon/archive/upstream/${PV}.tar.gz -> ${P}.tar.gz"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="amd64 x86"
14 IUSE="static-libs svg"
15
16 RDEPEND="dev-libs/libxml2:2
17         media-libs/libsdl
18         media-libs/sdl-image
19         media-libs/sdl-mixer
20         media-libs/sdl-net
21         media-libs/sdl-ttf
22         media-libs/sdl-pango
23         svg? (
24                 gnome-base/librsvg:2
25                 media-libs/libpng:0
26                 x11-libs/cairo
27         )"
28 DEPEND="${RDEPEND}
29         virtual/pkgconfig"
30
31 S=${WORKDIR}/t4kcommon-upstream-${PV}
32
33 src_prepare() {
34         epatch "${FILESDIR}"/${P}-libpng.patch
35 }
36
37 src_configure() {
38         econf \
39                 $(usex svg "" "--without-rsvg") \
40                 $(use_enable static-libs static)
41 }
42
43 src_install() {
44         default
45         use static-libs || prune_libtool_files --all
46 }