0a374c9a6bd5050cb17156ec8085e07276fd5f19
[gentoo.git] / dev-erlang / xmpp / xmpp-1.2.5.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit rebar
7
8 DESCRIPTION="XMPP parsing and serialization library on top of Fast XML"
9 HOMEPAGE="https://github.com/processone/xmpp"
10 SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
11         -> ${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
16 IUSE="test"
17
18 RDEPEND=">=dev-erlang/ezlib-1.0.4
19         >=dev-erlang/fast_tls-1.0.14
20         >=dev-erlang/fast_xml-1.1.34
21         >=dev-erlang/p1_utils-1.0.13
22         >=dev-erlang/stringprep-1.0.14
23         dev-lang/erlang"
24 DEPEND="${RDEPEND}"
25
26 DOCS=( CHANGELOG.md )
27
28 src_prepare() {
29         rebar_src_prepare
30         rebar_fix_include_path fast_xml
31 }