sys-devel/clang: x86 stable (bug #644814)
[gentoo.git] / dev-erlang / lager / lager-3.2.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit rebar
7
8 DESCRIPTION="Logging framework for Erlang/OTP"
9 HOMEPAGE="https://github.com/basho/lager"
10 SRC_URI="https://github.com/basho/${PN}/archive/${PV}.tar.gz
11         -> ${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
16
17 DEPEND=">=dev-erlang/goldrush-0.1.8
18         >=dev-lang/erlang-17.1"
19 RDEPEND="${DEPEND}"
20
21 DOCS=( README.md TODO )
22
23 src_prepare() {
24         rebar_src_prepare
25         # 'priv' directory contains only edoc.css, but doc isn't going to be built.
26         rm -r "${S}/priv" || die
27 }